Read 180 Performance Update

Incident Report for HMH Platform

Resolved

This incident has been resolved.
Posted Jan 29, 2025 - 14:11 EST

Update

We have released a solution to address the root cause of this issue. As a precautionary step our teams will continue closely monitoring performance in Read 180 today. An update will be provided here before the end of the day.
Posted Jan 29, 2025 - 09:35 EST

Update

Performance on Read 180 has remained normal. HMH teams have identified what we believe is the root cause of the problem and are working to apply a permanent solution to address this. An update will be provided tomorrow on or before 10:00AM ET.
Posted Jan 28, 2025 - 17:35 EST

Monitoring

Performance on Read 180 has returned to normal. We will continue monitoring performance and provide additional updates here.
Posted Jan 28, 2025 - 15:03 EST

Investigating

Read 180 is experiencing a service interruption. Teachers and Students are currently unable to launch the software and receive an error message when attempting to do so.

HMH teams are investigating this issue now and additional updates will be provided here as soon as possible. Thank you for your patience and we apologize for any inconvenience.
Posted Jan 28, 2025 - 14:42 EST
This incident affected: HMH Ed (Content and Resources).