Amira on Ed Service Disruption

Incident Report for HMH Platform

Resolved

Users are now able to launch Amira from Ed.
Posted May 06, 2025 - 11:07 EDT

Investigating

Please be advised that we are investigating a possible a service interruption for users attempting to launch Amira from Ed. Additional details will be provided here as soon as possible.
Posted May 06, 2025 - 10:35 EDT
This incident affected: HMH Ed (Content and Resources).