Classes and Content Not Loading on Ed

Incident Report for HMH Platform

Monitoring

Thank you for your patience. Action has been taken to resolve the issue. As a result, classes and content are once again loading as expected. We will continue to closely monitor performance on Ed.
Posted Jan 09, 2026 - 12:45 EST

Investigating

During the monitoring period we've observed some classes and content not displaying as expected. HMH engineers continue to investigate.
Posted Jan 09, 2026 - 10:02 EST

Monitoring

Classes and content on Ed are now displaying as expected. We are closely monitoring performance and will update this page again tomorrow. Thank you.
Posted Jan 08, 2026 - 15:50 EST

Investigating

We are currently investigating an issue where classes and some content are not displaying on Ed. We apologize for the inconvenience and will post another update as soon as more information is available.
Posted Jan 08, 2026 - 14:52 EST
This incident affects: HMH Ed (Content and Resources).