Classcraft on Ed

Incident Report for HMH Platform

Resolved

This incident is now resolved.
Posted Mar 11, 2026 - 12:00 EDT

Monitoring

Thank you again for your patience. A fix has been implemented and Classcraft is now available for impacted users. Out of an abundance of caution, we will be monitoring this incident into the day tomorrow. If you experience any issues accessing Classcraft, please contact HMH Technical Support.
Posted Mar 10, 2026 - 13:39 EDT

Identified

The cause of Classcraft not displaying on Ed has been identified and we are currently working on a fix.
Posted Mar 10, 2026 - 12:42 EDT

Update

We are continuing to investigate the root cause of Classcraft not displaying on Ed. Thank you for your patience.
Posted Mar 10, 2026 - 12:13 EDT

Investigating

HMH engineering teams are currently investigating an issue where Classcraft is not visible on Ed. Another update will be provided here as soon as more information is available.
Posted Mar 10, 2026 - 11:07 EDT
This incident affected: HMH Ed (Content and Resources).