AWS service interruption has been resolved as of 10.20. HMH will continue to monitor for any residual impact as a result of this interruption.
Posted Oct 21, 2025 - 08:15 EDT
Update
Impacts to some products and services will continue while AWS takes action to resolve the disruption on the impacted zone. We continue to monitor the situation and will provide another update as soon as possible.
Posted Oct 20, 2025 - 17:23 EDT
Monitoring
We are aware of an ongoing disruption to AWS services which could still be impacting some HMH products, such as some content or videos not loading as expected. AWS has indicated they are making progress on resolving the issue and we continue to monitor this event closely.
Posted Oct 20, 2025 - 12:34 EDT
This incident affected: HMH Ed (Login, Content and Resources), ThinkCentral (Login, Content and Resources), and Holt McDougal Online (Login, Content and Resources).