Technical Support Phone Service

Incident Report for HMH Platform

Resolved

This issue has been resolved and the HMH Technical Support phone line is available.
Posted Aug 14, 2025 - 09:21 EDT

Update

Thank you for your patience.
Posted Aug 13, 2025 - 16:27 EDT

Identified

Please be aware that the HMH Technical Support phone number (800-323-9239) is currently unavailable. Visit our HMH Support site for additional support options including emailing and chat.
Posted Aug 13, 2025 - 16:26 EDT
This incident affected: Holt McDougal Online (Rostering).