Content on Waggle

Incident Report for HMH Platform

Identified

The cause of some content not loading on Waggle has been identified. HMH engineers are currently working on implementing a fix.
Posted Feb 20, 2026 - 15:18 EST

Investigating

We are currently investigating an issue where some content on Waggle is not loading as expected. Engineering teams are actively engaged. We apologize for the inconvenience and will post another update here as soon as more information is available.
Posted Feb 20, 2026 - 13:59 EST
This incident affects: HMH Ed (Content and Resources).